Excel: „Wenn Zelle (nicht) leer, dann...“ – Funktion

Robert Schanze

Wenn eine Zelle in Excel leer oder nicht leer ist, könnt ihr eine Rechnung ausführen lassen, eine Zahl oder einen Text ausgeben. Wir zeigen, wie das funktioniert.

14.371
Excel: Wenn Zelle nicht leer, dann... (Video-Tutorial)

Das Excel-Beispiel könnt ihr euch als Datei hier herunterladen.

Excel: „Wenn Zelle nicht leer, dann…“ – Funktion

Beispiel: Wenn eine Zelle nicht leer ist, dann soll Excel 5 addieren. Falls die Zelle leer ist, soll nichts geschehen.

So geht’s:

  1. Ihr nutzt die Excel-Funktion WENN mit der Syntax:
    WENN(Prüfung;[Dann_Wert];[Sonst_Wert])
  2. In unserem Beispiel lautet die Formel also
    =WENN(A2=””;””;A2+5)

Wie im Video gezeigt, könnt ihr natürlich auch einen Text oder einen Wert ausgeben lassen, wenn die Zelle leer oder nicht leer ist.

Hinweis: Das Beispiel funktioniert nur mit Zahlen, da Excel 5 nicht zu einem Text addieren kann. Es entsteht die Ausgabe #WERT! Wenn ihr das verhindern wollt, schaut euch die Funktion ISTFEHLER an.

Excel: „Wenn Zelle leer, dann…“ – Funktion

Wenn ihr statt im obigen Beispiel wollt, dass die bestimmte Aktion ausgeführt wird, wenn die Zelle leer ist, sieht die Formel in unserem Beispiel so aus:
=WENN(A2=””;A2+5;A2)

Auch hier könnt ihr eine Rechnung, Text oder eine bestimmte Zahl ausgeben lassen.

Microsoft Office 2016 Home and Student
(Word, Excel, PowerPoint und OneNote)
Microsoft Office 2016 Home and Business
(Word, Excel, PowerPoint, OneNote und Outlook)

ISTLEER-Funktion prüft, ob eine Zelle leer ist

Wer nur den Status prüfen will, ob eine Zelle leer ist, kann die Funktion ISTLEER nutzen:

  • Syntax: ISTLEER(Wert)

So geht’s:

  1. In unserem Beispiel lautet die Formel in Zelle D2  =ISTLEER(A2)
  2. Dabei wird in der Zelle ausgegeben, ob Zelle A2 leer ist (WAHR) oder nicht (FALSCH).

In Kombination mit einer WENN-Funktion könnt ihr die ISTLEER-Funktion nutzen, um weitere Rechnungen oder Ausgaben zu starten. Schaut euch dazu unser obiges Video an.

Weitere Themen: Microsoft

Neue Artikel von GIGA SOFTWARE