Wenn-Dann-Funktion in Excel: Anwendung + Beispiele

Marco Kratzenberg
6

Die Wenn-Dann-Funktion in Excel dient dazu, bestimmte Aktionen in Zellen durchzuführen, wenn eine selbst definierbare Voraussetzung stimmt. Wie man sie anwendet, erkläre ich Euch hier mit Beispielen.

Wenn-Dann-Funktion in Excel: Anwendung + Beispiele

Die Wenn-, bzw. Wenn-Dann-Funktion von Excel wird als Formel auf einzelne Zellen, Spalten oder Reihen angewendet. Der generelle Aufbau sieht folgendermaßen aus:

=WENN(BEDINGUNG;DANN;ANSONSTEN)

Die Regeln für die Wenn-Dann-Funktion in Excel lauten:

  • Gestartet wird also immer mit dem Gleichheitszeichen.
  • Dann folgt ein groß geschriebenes WENN.
  • Danach kommen eine öffnende und schließende Klammer, zwischen denen sich die eigentliche Bedingung zum Rechnen befindet.
  • Die Teile innerhalb der Klammer werden durch das Semikolon getrennt.

Wenn Dann Funktion in Excel: Datenausgabe

Ich fange mit einer einfachen Formel an. Dazu denken wir uns mal einen ganz einfachen Fall. In eine Liste von Schülern wird die jeweilige Note eingetragen.

Die Wenn-Dann-Funktion in Excel soll dann dahinter ausgeben, ob der Schüler versetzt wurde, oder eben nicht. Die Grenze zur Versetzung ist die Note 4. Alles was schlechter (also größer) als 4 ist bleibt sitzen.

Also lautet die Formel im Klartext etwa:

WENN der Wert in Zelle X kleiner als 5 ist, gib aus JA, ansonsten gib aus Nein

Gibt man nun erst den Schülernamen ein, dann die Note, so steht in Spalte 3 automatisch, ob der Schüler versetzt wurde oder nicht. Von Note 1 bis 4 steht dort Ja, bei 5 und 6 steht dort Nein. Und die Formel wäre folgendermaßen aufgebaut. Wobei ich mal voraussetze, dass die Note in Spalte E eingetragen wird. Diese Formel kann man kopieren und auf die anderen Zellen übertragen.

=WENN(E3 <5;“Ja”;“Nein”)

Hier seht Ihr also die drei Bestandteile der Formel. Die Bedingung in Rot, Was dann passiert in Grün und was ansonsten passiert in Orange. Auszugebender Text muss, damit er nicht zu Fehlern führt und fehlinterpretiert wird, immer in Anführungszeichen gesetzt werden. Das kann auch ein ganzer Satz sein. Alles innerhalb der Anführungszeichen zählt zu diesem Formelabschnitt. Was dabei herauskommt, sehen wir oben im Bild.

Für die Prüfung können wir verschiedene Bedingungen einsetzen. Da wären:

  • Gleich = bzw. Ungleich <>
  • Kleiner < bzw. Größer >
  • Kleiner oder gleich <= bzw. Größer oder gleich >=

Man kommt meist auf verschiedene Weise zum Ziel. In der obigen Formel prüft Ihr, ob ein Wert kleiner als 5 ist (wobei wir übrigens auch Zahlen mit Nachkommstellen verwenden können) und in dem Fall tritt das DANN-Ergebnis ein. Man hätte das auch umdrehen können. Also prüfen, ob der Wert größer als 4 ist und in diesem Fall als DANN-Wert “Nein” setzen. Das Ergebnis ist theoretisch dasselbe. Aber wenn man genau hinguckt wird man folgendes feststellen: Im ersten Beispiel wird man auch mit einer 4,9 noch versetzt. Im zweiten Beispiel ist die 4 eine harte Grenze. An so etwas sollte man vorher denken!

Wenn Dann Funktion in Excel auf einen Bereich anwenden

Will man so eine Formel gleich auf einen Eingabebereich anwenden, dann muss der lediglich in der Formel definiert werden. In dem Fall steht in der Bedingung der Bereich als Start- und Endzelle, getrennt durch einen Doppelpunkt:

=WENN(E3:E6<5;”Ja”;”Nein”)

Das lohnt sich, wenn man den Quelldatenbereich vorher genau kennt. Ansonsten Könnt Ihr ruhig erst einmal die Daten eintragen und dann die Formel aus der ersten Ergebniszelle auf in Folgezellen kopieren.

Wenn Dann Funktion in Excel verschachteln

Hier nehmt Ihr mal einen anderen Fall an. Ihr führt ein Kassenbuch und müsst den Eintritt verwalten. Bis zum Alter von 12 kostet der Eintritt 3,00 Euro. Von 12 bis 20 kostet der Eintritt 5,00 Euro. Alle darüber zahlen 8,00 Euro. Ganz einfach, oder?

Wie prüft man das nun? Bei nur zwei Bedingungen mit einer Grenze von 12 wäre das leicht. Die erste Bedingung wäre “alles kleiner-gleich 12 zahlt 3″. Das ANSONSTEN wäre: “Alle anderen zahlen 8 Euro”. Also etwa so:

=WENN(B2<=12; 3;8)

Aber Ihr müsst ja zwei Bedingungen prüfen, bevor Ihr zu einem ANSONSTEN gelangt. Technisch gesehen geschieht das so: Zuerst prüft Ihr die erste Bedingung und legt fest, was dann passiert.

Also “B2<=12; 3″. Doch dahinter schiebt Ihr eine weitere Prüfung ein und setzt sie an die Stelle, die sonst für den dritten Teil der Formel gedacht ist. Das sieht etwa so aus:

=WENN(B2<=12;3;WENN(B3<=20;5;8))

Will man diese Wenn-Dann Funktion von Excel in Klartext übersetzen, kann man das so ausdrücken:

  • Wenn der Wert in der Zelle kleiner-gleich 12 ist, dann setze 3 ein.
  • Wenn er darüber hinaus aber noch kleiner-gleich 20 ist, setze 5 ein.
  • Ansonsten setze 8 ein.

Es wird also erst die erste Bedingung geprüft. Danach wird geprüft, ob der Wert unter eine zweite Bedingung fällt (alles zwischen 13 und 20). Ist das der Fall, dann gibt es eine zweite Ausgabe. Und wenn keine dieser beiden Bedingungen zutrifft, dann erst tritt der ANSONSTEN-Fall ein.

Das war nur eine kleine Einführung und eine Anregung, was man mit dieser Formel-Funktion alles machen könnte. Es ist natürlich noch viel mehr möglich und auch die Verschachtelungstiefe ist ausbaubar. Fangt erst einmal mit Berechnungen an, die ihr selbst noch auf einen Blick nachvollziehen könnt.

Weitere Themen: Microsoft Office 2013, Microsoft Office 2010, Microsoft

Neue Artikel von GIGA SOFTWARE