Bedingungen in Excel mit UNGLEICH - Einführung

Marco Kratzenberg

In Excel mit Operatoren wie UNGLEICH oder GLEICH zu arbeiten, kann uns viel Analysearbeit abnehmen. Wie Excel UNGLEICH behandelt und was man damit machen kann, erklären wir hier.

Video: Fünf weitere Tipps für Microsoft Excel

Fünf Tipps für Microsoft Excel.

Operatoren wie UNGLEICH, GLEICH, GRÖSSER ALS nutzen wir im Rahmen der Excel Wenn-Dann-Funktion. Die Regeln sind recht einfach. Hier lautet die Bedingung:

„Wenn die Werte in einem Bereich eine Bedingung erfüllen, dann soll dies passieren -ansonsten das!“. Also beispielsweise: Wenn die Werte in der Spalte Temperatur größer als 15 sind, dann gib aus Frühling. Sind sie niedriger, gib aus Winter. Wie man solche Wenn-Dann-Bedingungen in Excel mit Ungleich verknüpft, will ich hier anhand von Beispielen erläutern.

Excel: Operator Ungleich

In Excel ist Ungleich nur einer der Operatoren, die in Wenn-dann-Funktionen genutzt werden können. Insgesamt gibt es die sechs Operatoren Gleich und Ungleich, Kleiner und Größer sowie Kleiner oder gleich bzw. Größer oder gleich. Das Zeichen für Ungleich in Excel ist <>.

Im Grunde ist der Excel-Operator Ungleich das genaue Gegenteil des Operators Gleich. Und man kann ihn dementsprechend nahezu identisch einsetzen, wenn man die Bedingung richtig fasst. Ein kleines Beispiel: 5 Kollegen sollen erraten, an welche Zahl zwischen 1 und 20 man denkt. Man denkt an die 15. Nun soll durch eine Wenn-dann-Funktion neben jedem Kollegen entweder daneben oder Treffer ausgegeben werden.

Die Bedingung könnte also sein: Wenn der Wert in der Zelle GLECH 15 ist, gib aus Treffer, ansonsten daneben. Dasselbe Ergebnis können wir mit Ungleich erreichen. Dann lautet die Bedingung aber: Wenn der Wert der Zelle UNGLEICH 15 ist, gib aus Daneben, ansonsten Treffer. Sinn macht Ungleich in Excel also erst, wenn man Bedingungen verschachtelt. Der Fall kann in einer komplexeren Bedingung vorkommen.

Bilderstrecke starten
11 Bilder
Diese 10 verrückten Projekte wurden tatsächlich in Excel umgesetzt!

In Excel UNGLEICH anwenden

In Excel ist Ungleich ein Operator. Also so etwas wie eine Entscheidungsstelle, was im weiteren Verlauf geschehen soll. Wenn-Dann-Funktionen sind folgendermaßen aufgebaut:

=WENN(BEDINGUNG;DANN;ANSONSTEN)

Die drei Teile der Bedingung werden jeweils durch ein Semikolon getrennt. Zuerst kommt also die Bedingung mit unserem Operator. Diese kann beispielsweise lauten:

  • A1<>6 – Dann soll etwas passieren, wenn der Wert nicht der 6 entspricht.
  • A1<>““ – Hier stehen die beiden Anführungszeichen (ohne etwas dazwischen) für eine leere Zelle. Es soll also etwas passieren, wenn die Zelle leer ist.

Gefolgt wird die Bedingung von dem, was passieren soll WENN der Ausgangswert ungleich ist. Und anschließend von dem, was passieren soll, wenn der Wert gleich ist.

Beispiel:

=WENN(D2<>““;“Daten vorhanden“;“Keine Daten“)

Das bedeutet im Klartext: Wenn die Zelle D2 UNGLEICH Leer ist, dann Daten vorhanden ausgeben. Ansonsten Keine Daten ausgeben. Das ist eine etwas komplizierte Denkweise, die mit dem Operator GLEICH genauso zu lösen ist.

In dem Fall hätte man auch den Operator GLEICH anwenden können. Nur müssen dann die Ausgabefelder umgedreht werden. Also Keine Daten, wenn es GLECH LEER ist und Daten vorhanden in jedem anderen Fall.

Zu den Kommentaren

Kommentare zu diesem Artikel

Weitere Themen

Neue Artikel von GIGA SOFTWARE

  • Skype-Konto löschen oder deaktivieren: So klappt's

    Skype-Konto löschen oder deaktivieren: So klappt's

    Zwar könnt ihr euer Skype-Konto löschen, aber das hat möglicherweise auch Konsequenzen in anderen Bereichen. Wie ihr das macht, worauf ihr achten müsst und wann ihr euren Skype-Account nur deaktivieren solltet, erklären wir euch hier.
    Marco Kratzenberg 1
  • Skype-Login: Anmelden, neues Konto erstellen, einloggen und einrichten

    Skype-Login: Anmelden, neues Konto erstellen, einloggen und einrichten

    Skype zählt weltweit nach wie vor zu den beliebtesten systemübergreifenden Telefonie- und Chat-Anwendungen. Mit einem Skype-Login könnt ihr auf jedem Gerät Video-Telefonate führen, euch Nachrichten oder Dateien schicken und sogar Video-Konferenzen abhalten. Wie ihr ein Skype-Konto erstellt, euch dort einloggt und Skype einrichtet, erklären wir euch hier.
    Marco Kratzenberg
  • TreeSize Free Portable

    TreeSize Free Portable

    Der TreeSize Free Portable Download bringt euch die portable Ausgabe des Tools zur detaillierten Analyse von Festplatten und anderen Datenträgern, welche euch hilft herauszufinden, welche Dateien und Ordner auf euren Datenträgern am meisten Speicherplatz verbrauchen.
    Marvin Basse
* gesponsorter Link