Excel: Matrixformel erstellen & nutzen – so geht's

Robert Schanze

Mit einer Matrixformel könnt ihr in Excel mehrere Berechnungen auf einmal durchführen und sofort mit den Ergebnissen weiterrechnen. Wir zeigen, wie das geht.

Mit Matrixformeln lassen sich komplexe Berechnungen auf einen Schlag abarbeiten, wofür ansonsten mehrere einzelne Rechenschritte nötig wären. Wir zeigen euch das Ganze am Beispiel einer Umsatzberechnung im Video:

Excel: Matrixformel erstellen und verwenden (Tutorial).

Excel: Beispielrechnung ohne Matrixformel

Beispiel: Wir haben auf dem Markt Äpfel, Birnen und Erdbeeren verkauft und möchten unseren Umsatz berechnen. Wir könnten nun folgende vier Berechnungen durchführen:

  1. Menge Äpfel x Verkaufserlös Äpfel = Umsatz Äpfel
  2. Menge Birnen x Verkaufserlös Birnen = Umsatz Birnen
  3. Menge Erdbeeren x Verkaufserlös Erdbeeren = Umsatz Erdbeeren
  4. Umsatz Äpfel + Umsatz Birnen + Umsatz Erdbeeren = Gesamtumsatz

Statt der vier Einzelrechnungen lässt sich das Ganze aber auch in einer einzigen Matrixformel berechnen.

Excel: Beispielrechnung mit Matrixformel

Mit der Matrixformel sparen wir uns alle obigen Zwischenschritte und kommen gleich zum Ergebnis:

  1. Klickt in eine leere Zelle, wo der Gesamtumsatz berechnet werden soll.
  2. Gemäß unseres obigen Beispiels geben wir =SUMME(C3:C5*D3:D5) ein und drücken [Strg] + [Shift] + [Enter].
  3. Durch die Tastenkombination weiß Excel, dass hier mit Matrizen gerechnet werden soll (Matrixformel).

Ein anderes Beispiel einer Matrixformel zeigen wir euch im Excel-Tutorial zur Häufigkeitenberechnung. Das oben gezeigte Beispiel kann man alternativ übrigens auch mit der Funktion SUMMENPRODUKT berechnen.

Diese sogenannten Matrixformeln werden auch CSE- oder Array-Formeln genannt: Sie berechnen zwei oder mehr Matrizen und geben das Ergebnis erneut in Form einer Matrix aus.
Bilderstrecke starten
11 Bilder
Diese 10 verrückten Projekte wurden tatsächlich in Excel umgesetzt!

Was ist also eine Matrixformel?

  • Während eine Formel mit einzelnen Zellenbezügen rechnet, rechnet eine Matrixformel mit mehreren Zellen beziehungsweise Spalten gleichzeitig.
  • In unserem Beispiel werden die Matrix „Menge“ und die Matrix „Preis pro Stück“ in einer Matrixformel miteinander multipliziert und anschließend per SUMME-Funktion addiert.
  • Damit Excel eine Formel als Matrixformel erkennt, muss bei Abschluss die Tastenkombination [Strg] + [Shift] + [Enter] gedrückt werden.

Zu den Kommentaren

Kommentare zu diesem Artikel

Weitere Themen

Neue Artikel von GIGA SOFTWARE

  • Firefox: Startpage als Standardsuchmaschine hinzufügen – so geht's

    Firefox: Startpage als Standardsuchmaschine hinzufügen – so geht's

    Die Suchmaschine Startpage leitet eure Suchanfragen an Google weiter und anonymisiert dabei eure Daten. Wir zeigen, wie ihr Startpage.com in Deutsch als Standardsuchmaschine in eurem Firefox-Browser einrichtet und welche Einstellungen ihr danach genauer anschauen solltet.
    Robert Schanze
  • FurMark

    FurMark

    Mit dem FurMark Download treibt ihr eure Grafikkarte an die Belastungsgrenze. Daher stellt das Programm ein ideales Tool dar, um GPU- und Speicher-Übertaktung zu testen.
    Marvin Basse
* Werbung