Ähnlich wie Microsofts kostenpflichtiges Pendant Excel bietet das Tabellenkalkulationsprogramm Calc aus dem OpenOffice Download eingebaute Funktionen an, um die Berechnung in Tabellen zu vereinfachen und zu automatisieren. Um zu ermitteln, wie oft ein bestimmter Wert in einem Tabellenbereich vorkommt, verwendet man in OpenOffice die ZÄHLENWENN-Funktion.

 

OpenOffice

Facts 

Die ZÄHLENWENN-Funktion bietet eine einfache Möglichkeit, Häufigkeitsverteilungen in einer Tabelle zu ermitteln. So können Sie schnell ermitteln, wie oft ein angegebener Wert in einer Tabelle auftaucht.

Haben Sie eine Tabellenspalte mit 100 Zellen gegeben, in denen Zufallszahlen von 1 bis 10 stehen, müssen Sie nicht die komplette Spalte durchzählen, sondern können mit der ZÄHLENWENN-Funktion gezielt und automatisiert die Häufigkeiten der einzelnen Werte anzeigen lassen. Die Struktur von ZÄHLENWENN sieht dabei wie folgt aus:

=ZÄHLENWENN(Tabellenbereich; Bedingung)

Aufruf der OpenOffice ZählenWenn-Funktion

OpenOffice ZählenWenn Aufruf
Mit der ZählenWenn-Berechnung können Sie herausfinden, wie oft ein Wert in einer OpenOffice-Tabelle enthalten ist.

Rufen Sie den Funktions-Assistenten von OpenOffice auf, um die ZÄHLENWENN-Funktion zu erreichen. Markieren Sie den Bereich, in dem Sie die Häufigkeiten von Werten bestimmen möchten und geben Sie den Wert an, mit dem verglichen werden soll. Auch hier können Sie einen festen Wert eintragen oder den Wert aus einer anderen Zelle übernehmen.

Reguläre Ausdrücke mit der OpenOffice ZählenWenn-Funktion

OpenOffice ZählenWenn Reguläre Ausdrücke
Mit der ZählenWenn-Rechnung von OpenOffice können Sie auch Zeichenketten vergleichen

Sie müssen ZÄHLENWENN nicht ausschließlich mit Zahlenwerten verwenden, sondern können auch Zeichenketten miteinander vergleichen und sogar reguläre Ausdrücke in der Abfrage verwenden. Mit der Funktion ZÄHLENWENN(A1:A10;“.*en“) zählen Sie so zum Beispiel die Anzahl der Zellen zwischen A1 und A10, in denen ein Wort vorkommt, das auf „en“ endet.

Hierfür müssen Sie allerdings unter „Extras“ > „Optionen“ > „OpenOffice.org Calc“ > „Berechnen“ die Option „Reguläre Ausdrücke in Formeln ermöglichen“ aktivieren. Die Zeichen „.“ und „*“ stehen nämlich als Platzhalter. Der Punkt repräsentiert ein beliebiges Zeichen, während das Sternchen eine beliebige Anzahl des vorgehenden Zeichens erlaubt. Mit dieser Einstellung werden alle Wörter gezählt, die eine beliebige Zeichenfolge beinhalten, welche mit einem „en“ abschließt.