Excel: SUMMENPRODUKT anwenden – so geht's

Robert Schanze

Die Excel-Funktion SUMMENPRODUKT multipliziert nebeneinander stehende Arrays miteinander und gibt ihre Summe aus. Wir zeigen, wie ihr die Funktion anwendet.

Unser Video-Tutorial zeigt, wie ihr ein SUMMENPRODUKT berechnen könnt:

Excel: So berechnet ihr ein SUMMENPRODUKT (Tutorial).

Excel: SUMMENPRODUKT

Syntax: SUMMENPRODUKT(Array1;[Array2];[Array3];…)

  • Array1 ist das erste Argument, dessen Komponenten multipliziert und addiert werden sollen.
  • Array2, Array3, … sind optional. Excel kann 2 bis 255 Array-Argumente multiplizieren und anschließend addieren.
  • Achtet darauf, dass die Arrays, mit denen ihr rechnen möchtet, die gleiche Spalten- beziehungsweise Zeilenanzahl besitzen, ansonsten gibt Excel den Fehler #WERT! aus.
  • Steht in einer Zelle Text, wird die Zelle von Excel so behandelt, als hätte sie den Wert 0.

Beispiel für ein SUMMENPRODUKT

Auf dem Markt haben wir Pfirsiche, Bananen und Kirschen verkauft. Nun wollen wir unseren Gesamtumsatz ausrechnen und haben folgende Tabelle mit den jeweiligen Mengen- und Preis-Angaben:

  1. In den Zellen B2 bis B4 stehen die Mengen.
  2. In den Zellen C2 bis C4 die zugehörigen Stückpreise.
  3. In der Zelle C6 soll der Gesamtumsatz stehen.
  4. Wir schreiben dort zunächst die Formel =SUMMENPRODUKT(B2:B4;C2:C4) hinein und drücken Enter.
  5. Excel multipliziert nun die Zellen B2 mit C2, B3 mit C3 und B4 mit C4. Die Zwischenergebnisse werden dann summiert zum Endergebnis (hier: Gesamtumsatz).

Die Funktion SUMMENPRODUKT ersetzt diese ganzen Einzelberechnungen, indem es in unserem Beispiel zeilenweise alles multipliziert und die jeweiligen Zwischenergebnisse dann addiert. Das Gleiche lässt sich übrigens auch mit einer Matrixformel berechnen ohne die Funktion SUMMENPRODUKT.

Falls etwas nicht funktioniert haben sollte oder ihr noch anderweitige Fragen habt, schreibt sie uns bitte in unseren Kommentarbereich unterhalb dieser Anleitung.

 

Zu den Kommentaren

Kommentare zu diesem Artikel

* Werbung