Die Excel-Funktionen „ANZAHL“ und „ANZAHL2“ zählen die Zellen, die einen Inhalt haben. Die Funktionen „ZÄHLENWENN“ und „ZÄHLENWENNS“ zählen nur die Zellen mit Inhalt, die von euch festgelegte bestimmte Bedingungen erfüllen. Wie das geht, seht ihr hier.

 
Microsoft Excel 2019
Facts 

Was machen die Excel-Funktionen „ANZAHL“ und „ANZAHL2“?

Die Funktion „ANZAHL“ zählt nur die Zellen, die eine Zahl enthalten. Die Funktion „ANZAHL2“ zählt alle Zellen mit Inhalt – also auch solche, die Text oder Leerzeichen enthalten. Enthält eine Zelle also nur ein Leerzeichen, sieht die Funktion „ANZAHL2“ diese Zelle als gefüllt an und zählt sie mit. Um eine Zelle komplett zu leeren, markiert ihr diese und drückt anschließend die Entf-Taste.

Bilderstrecke starten(11 Bilder)
Diese 10 verrückten Projekte wurden tatsächlich in Excel umgesetzt!

Formel der Funktion „ANZAHL“

=ANZAHL(A1:A11)

Formel der Funktion „ANZAHL2“

=ANZAHL2(A1:A11)

„ANZAHL“ und „ANZAHL2“ in Excel nutzen

„ANZAHL“ zählt nur Zellen mit Zahlen. „ANZAHL2“ zählt auch Zellen mit Text oder Leerzeichen. Bild: GIGA
„ANZAHL“ zählt nur Zellen mit Zahlen. „ANZAHL2“ zählt auch Zellen mit Text oder Leerzeichen. (Bildquelle: GIGA)
  1. Wählt mit der Maus zunächst die Zelle aus, die das Ergebnis der Funktion anzeigen soll.
  2. Gebt eine der Formeln dann in die Befehlszeile oberhalb der Tabelle ein. In unserem Beispiel haben wir den Zellbereich von A1 bis A11 gewählt. Ihr könnt diesen bei euch natürlich an eure Bedürfnisse anpassen.
  3. Zellbereiche lassen sich manuell per Tastatur in die Formel eingeben oder ihr markiert die Zellbereiche mit der Maus.
  4. Dazu gebt ihr den Anfang der Formel und die öffnende Klammer ein und wählt anschließend den Bereich aus, indem ihr diesen mit der Maus markiert. Danach folgt die schließende Klammer.
  5. Bestätigt die Formel mit [Enter].

Diese 5 Excel-Tricks sollte jeder kennen:

Fünf Tipps für Microsoft Excel Abonniere uns
auf YouTube

Die Excel-Funktion „ZÄHLENWENN“ zählt nur bestimmte Werte

Angenommen, ihr erstellt eine Teilnehmerliste für ein Seminar. Wer teilnimmt, wird mit „ja“ eingetragen, sonst mit „nein“. Mit der Funktion „ZÄHLENWENN“ zählt ihr in Excel dann alle „JA“-Einträge und gebt das Ergebnis in einer Zelle aus.

Formel der Funktion „ZÄHLENWENN“

=ZÄHLENWENN(B2:B8;“ja“)

„ZÄHLENWENN“ in Excel nutzen

„ZÄHLENWENN“ zählt die Zelle nur, wenn der Inhalt bestimmte Bedingungen erfüllt. Bild: GIGA
„ZÄHLENWENN“ zählt die Zelle nur, wenn der Inhalt bestimmte Bedingungen erfüllt. (Bildquelle: GIGA)
  1. Wählt mit der Maus zunächst die Zelle aus, die das Ergebnis der Funktion anzeigen soll.
  2. Gebt die Formel ein. In unserem Beispiel haben wir den Zellbereich von B2 bis B8 gewählt. Ihr könnt diesen bei euch natürlich an eure Bedürfnisse anpassen.
  3. Danach steht ein Semikolon, gefolgt von der Bedingung. In unserem Beispiel lautet die Bedingung „ja“. Da die Bedingung hier ein Text ist, steht sie in Anführungszeichen.
  4. Dahinter folgt die geschlossene Klammer.
  5. Bestätigt die Formel mit [Enter].

„ZÄHLENWENNS“ mit mehreren Bedingungen

Die Funktion „ZÄHLENWENNS“ zählt sogar Zelleninhalte aus mehreren Zellbereichen, wenn diese bestimmte Bedingungen erfüllen. Angenommen ihr habt die Teilnehmerliste aus dem obigen Beispiel der Excel-Funktion „ZÄHLENWENN“. Nun möchtet ihr euch aber zusätzlich anzeigen lassen, wie viele Teilnehmer für das Seminar bezahlt haben. Denn das ist die letztlich fertige Teilnehmerliste. Das Ganze sieht dann beispielsweise aus wie folgt.

Formel der Funktion „ZÄHLENWENNS“

=ZÄHLENWENNS(B2:B8;“ja“;C2:C8;“ja“)

„ZÄHLENWENN“ in Excel nutzen

„ZÄHLENWENNS“ zählt Zellen mehrere Zellbereich nur, wenn deren Zelleninhalte bestimmte Bedingungen erfüllen. Bild: GIGA
„ZÄHLENWENNS“ zählt Zellen mehrere Zellbereich nur, wenn deren Zelleninhalte bestimmte Bedingungen erfüllen. (Bildquelle: GIGA)
  1. Wählt mit der Maus zunächst die Zelle aus, die das Ergebnis der Funktion anzeigen soll.
  2. Gebt die Formel ein. Zunächst gebt ihr den ersten Zellbereich an sowie deren Bedingung, danach folgt der zweite Zellbereich und deren Bedingung. In unserem Beispiel haben wir den ersten Zellbereich von B2 bis B8 gewählt mit der Bedingung „ja“. Danach kommt der zweite Zellbereich von C2 bis C8 mit der Bedingung „ja“. Ihr könnt diese bei euch an eure Bedürfnisse anpassen.
  3. Die jeweiligen Eingaben sind durch ein Semikolon getrennt.
  4. Am Ende folgt die geschlossene Klammer.
  5. Bestätigt die Formel mit [Enter].