Excel: „Wenn Zelle (nicht) leer, dann...“ – Funktion

Robert Schanze

Wenn eine Zelle in Excel leer oder nicht leer ist, könnt ihr eine Rechnung ausführen lassen, eine Zahl oder einen Text ausgeben. Wir zeigen, wie das funktioniert.

Excel: Wenn Zelle nicht leer, dann... (Video-Tutorial).

Das Excel-Beispiel könnt ihr euch als Datei hier herunterladen.

Excel: „Wenn Zelle nicht leer, dann…“ – Funktion

Beispiel: Wenn eine Zelle nicht leer ist, dann soll Excel 5 addieren. Falls die Zelle leer ist, soll nichts geschehen.

So geht’s:

  1. Ihr nutzt die Excel-Funktion WENN mit der Syntax:
    WENN(Prüfung;[Dann_Wert];[Sonst_Wert])
  2. In unserem Beispiel lautet die Formel also
    =WENN(A2=““;““;A2+5)

Wie im Video gezeigt, könnt ihr natürlich auch einen Text oder einen Wert ausgeben lassen, wenn die Zelle leer oder nicht leer ist.

Hinweis: Das Beispiel funktioniert nur mit Zahlen, da Excel 5 nicht zu einem Text addieren kann. Es entsteht die Ausgabe #WERT! Wenn ihr das verhindern wollt, schaut euch die Funktion ISTFEHLER an.

Bilderstrecke starten
11 Bilder
Diese 10 verrückten Projekte wurden tatsächlich in Excel umgesetzt!

Excel: „Wenn Zelle leer, dann…“ – Funktion

Wenn ihr statt im obigen Beispiel wollt, dass die bestimmte Aktion ausgeführt wird, wenn die Zelle leer ist, sieht die Formel in unserem Beispiel so aus:
=WENN(A2=““;A2+5;A2)

Auch hier könnt ihr eine Rechnung, Text oder eine bestimmte Zahl ausgeben lassen.

Besonders günstig gibt es Microsoft Office als Home- und Studentenversion 2016 bei Amazon:

Microsoft Office Home und Student 2016 bei Amazon kaufen *

ISTLEER-Funktion prüft, ob eine Zelle leer ist

Wer nur den Status prüfen will, ob eine Zelle leer ist, kann die Funktion ISTLEER nutzen:

  • Syntax: ISTLEER(Wert)

So geht’s:

  1. In unserem Beispiel lautet die Formel in Zelle D2  =ISTLEER(A2)
  2. Dabei wird in der Zelle ausgegeben, ob Zelle A2 leer ist (WAHR) oder nicht (FALSCH).

In Kombination mit einer WENN-Funktion könnt ihr die ISTLEER-Funktion nutzen, um weitere Rechnungen oder Ausgaben zu starten. Schaut euch dazu unser obiges Video an.

Zu den Kommentaren

Kommentare zu diesem Artikel

Weitere Themen

Neue Artikel von GIGA SOFTWARE

  • Photoshop ohne Abo geht das? Ja und Nein

    Photoshop ohne Abo geht das? Ja und Nein

    Adobe hat irgendwann beschlossen, das gesamte Software-Angebot auf Online-Abos umzustellen – das passt nicht Jedem! Ob und wie ihr Photoshop ohne Abo kaufen könnt, erklären wir euch hier.
    Marco Kratzenberg
  • iOS 13

    iOS 13

    Das kommende Betriebssystem für iPhone und iPads ist iOS 13. Den Nachfolger von iOS 12 wird Apple voraussichtlich im Juni auf der WWDC vorstellen und im September veröffentlichen. Spannend dürfte das System vor allem für iPad-Besitzer sein.
    Sebastian Trepesch
  • PDF-XChange Editor

    PDF-XChange Editor

    Bis jetzt galt der PDF-XChange Viewer als eines unserer Lieblingsprogramme zum Betrachten und Nachbearbeiten von PDF-Dateien. Doch der PDF-XChange Editor aus dem gleichen Haus ist ein mehr als würdiger Nachfolger!
    Marco Kratzenberg 2
* gesponsorter Link