In unserem Excel-Beispiel seht ihr, wie ihr Zeichen und ganze Wörter in Zellen zählt. Außerdem seht ihr, wie ihr die Zeichen aus mehreren Zellen addiert ausgeben könnt.

 

Microsoft Excel 2019

Facts 

So zählt ihr Zeichen in Excel

Excel kann alle Zeichen innerhalb einer Zelle zählen. Dazu gehören Buchstaben, Zahlen, Sonderzeichen und Leerzeichen. Das geht so:

  1. Gebt in eine freie Zelle =LÄNGE ein.
  2. Bestätigt mit der Tab-Taste den angezeigten Vorschlag zur LÄNGE-Funktion.
  3. Gebt nun die Zelle ein, deren Zeichenlänge ihr zählen möchtet – etwa B2.
  4. Schließt die Klammer und drückt Enter.

In unserem Beispiel heißt der ganze Ausdruck =LÄNGE(B2) und wird in Zelle B4 ausgegeben:

So könnt ihr farbige Zellen zählen.

Formel auf größeren Zellenbereich ausweiten

  1. Klickt auf die Zelle mit der LÄNGE-Formel.
  2. Klickt mit der Maus auf den kleinen Punkt unten rechts der Zelle.
  3. Haltet die linke Maus gedrückt und zieht die Formel nach unten oder zur Seite, um sie auf anliegende Zellen zu erweitern.
  4. Excel trägt nun automatisch die richtigen Werte in diese Zellen ein.

Mehrere Zellen addieren mit SUMME

Falls ihr die Zeichen aus mehreren Zellen zählen und addieren möchtet, nutzt ihr zudem die SUMME-Funktion. In unserem folgenden Beispiel addieren wir die Zeichen der Zellen B2, B3 und B4.

Formel: =SUMME(LÄNGE(B2);LÄNGE(B3);LÄNGE(B4))

Wow, das haben sie wirklich in Excel gemacht:

Bilderstrecke starten(11 Bilder)
Diese 10 verrückten Projekte wurden tatsächlich in Excel umgesetzt!

So zählt ihr Wörter in Excel

  1. Hierfür nutzt ihr die Funktion =LÄNGE(#)-LÄNGE(WECHSELN(#;“ „;““))+1
  2. Statt der Raute (#) gebt ihr eure entsprechende Zelle ein, bei der die Wörter gezählt werden sollen, beispielsweise A2.
  3. Habt ihr mehrere solche Zellen, in denen die Wortanzahl anderer Zellen ausgegeben wird, könnt ihr diese mit der Summenfunktion zur Gesamtwortanzahl addieren.

Falls ihr noch Fragen zu Excel und der ZÄHLEN-Funktion habt, schreibt sie einfach in unseren Kommentarbereich unterhalb dieser Anleitung. Wir werden euch dann entsprechend weiterhelfen, sofern möglich.

Microsoft Office oder eine kostenlose Alternative?

Robert Schanze
Robert Schanze, GIGA-Experte für Windows, Android, Linux und Software.

Ist der Artikel hilfreich?